Sunday, November 20, 2011

Getting around a locked account in Windows 7

Last friday, my work laptop running Windows 7 was complaining that I needed to change the password. So, I did.

Over the weekend, I turned it on at home and tried to login. It was hooked up to my KVM switch, with an AZERTY keyboard on it. Between the mismatched keyboard layout and the new password, I managed to get the account locked. No new attempts to login to the account could be made. Even if I had the right password ! Windows kept complaining that "the account had been locked".

The solution was very simple :
1. Reboot the computer. This required holding the power button
2. Go to the BIOS menu
3. Change the computer's date . I moved it 3 days in the future.
4. Restart Windows

Voila - account no longer locked. I got to make more attempts, and managed to login.
I hope this helps somebody else. This is one OS security measure that was easily defeated.

Sunday, October 23, 2011

Back on Networked Blogs

After giving up on TwitterFeed, I am back on the Networked Blogs syndication application. There might be a 12 hr delay between my posts and the time they appear on Facebook and Twitter. But hopefully, they will not be lost, as was the case with Twitterfeed, unfortunately. This message will serve as a syndication test.

Saturday, October 22, 2011

Yamaha's uncompressed music destroyer

Two weeks ago, I purchased a Yamaha RX-A1000 7.receiver for my home theater. It replaced an older RX-V2500, which was moved to another room which was also in need of a receiver. The RX-A1000 was a floor model which came with no remote control or manual, but at one third the regular price. I setup everything, and it sounded great.

There was however one exception : an original retail CD of Zhu-Xiao Mei's Goldberg Variations, played from my trusty old Yamaha CDM-900 player, sounded execrable. Specifically, the highs of the piano in variation 1 were so exaggerated and aggressive that they almost sounded like those from an old shaky AM radio. It was so harsh to me as an audiophile, but still would have been obvious to anybody with decent hearing.

I was able quickly able to figure out that this was not due to the source CD or player : when I turned on the "Pure direct" feature of the receiver, the sound fortunately returned to what was expected. So, the degradation had to be due to some processing being done in the receiver.

However, I was running in "STRAIGHT" mode, with no DSP programs enabled. I couldn't figure out what was causing the problem. It took me a few days to figure out what it was.

Today, I received the proper remote from 1-800-REMOTES. It was time to finally elucidate this mystery.

I proceeded to undo all the YPAO calibration settings . But even after the parametric equalizer to "Flat" mode, the problem still remained. I had to dig into the manual, which I had printed from the PDF. It turns out that there are several processing options that are applied even in "STRAIGHT" mode.

One of them is the "Adaptive DRC". I disabled it. But that was not the issue.
What turned out to be the problem was the so-called "Compressed music enhancer". In my opinion, this really should be called "Uncompressed music destroyer", as this is a very unfortunate consequence of enabling it. I don't listen to compressed music, and thus cannot comment on whether it has any actual benefit.

This setting is enabled per-input, which is why I hadn't heard the problem with my other sources. And it was turned on for my "Audio 1" source to which the CDM-900's optical audio cable was connected.

The front display of the receiver shows the word "Enhancer" in small red type on the display when this is enabled. Not "Compressed music enhancer". This is a real misnomer. I wish it could be permanently disabled. If your new Yamaha receiver is sounding awful, this may be the reason why.

Overall, I want to be clear that I really love the sound that the receiver can produce once this processing gimmick is disabled. It is definitely a step up from the RX-V2500. I will be posting a full review on Amazon once I have fully configured everything in the best possible way to meet all my extensive home theater needs.

Tuesday, October 18, 2011

Gave up on TwitterFeed

Several times already, TwitterFeed stopped picking up any updates from my blog completely. The problem seems to last indefinitely. The first time this happened, I reported it, and it was resolved, but only for new posts. Old posts that were missed were never posted to either Twitter or Facebook. The problem has just happened again. Goodbye, Twitterfeed, it was nice known you.

Saturday, October 15, 2011

Incompatibility of the day : Gigabyte P35 ICH9R SATA controller vs FreeDOS

Two of my many home computers use older motherboards from Giga-byte. One is a P35-DS3R and another an EP35-DS4 . Both are based on the 2007-vintage Intel P35 chipset.

As I'm constantly shuffling disks, operating systems, and messing with various things, I often find myself unable to boot. Multiple operating systems on the same machine often have a way of messing with each other. Such is life.

For years, I have been using a very useful tool called DFSee to recover from such dreadful situations . I'm normally booting this tool from a CD-R . DFSee first boots to FreeDOS . On the two aforementioned motherboards, if the optical drive is connected to one of the SATA ports on the Intel controller, the boot process inexplicably hangs after word "FreeDOS" is displayed. This is very problematic. I have the latest - and last - BIOS release for these motherboards, so a fix will not be forthcoming from the manufacturer. There is a solution for this, however : disconnect the optical drive from the Intel SATA controller, and plug it into the Gigabyte JMicron-based 2-port SATA controller. FreeDOS will then successfully boot.

I'm not sure if this problem still exists on more recent Intel-based Gigabyte motherboards. I have two other more recent Gigabyte motherboards, which are AMD-based, and DFSee and FreeDOS boot fine regardless of which SATA controller the optical drives are connected to.

Sunday, October 2, 2011

Adding eSATA capability to the Roland VS-2400CD digital recorder. Part 1, redux

[Note: this is an update to a previously posted article. My former mod didn't complete successfully due to the unavailability of an UltraDMA-compatible male-to-male IDE cable. I started over with different parts and was finally able to complete the mod].

I have been the happy owner of a Roland VS-2400CD digital recorder studio since 2003. It is an all-in-one digital audio workstation. It has served me very well, with its 8 built-in mic preamps, 24 bit / 96 khZ DACs, hard drive, motorized faders, keyboard / mouse / VGA connections, you name it, it has got it.

Except for one glaring omission : any kind of computer connection. The Roland VS-2400CD has no USB port, not even USB 1.0 . There is an R-BUS connection. This is a proprietary Roland interface, which can only export 8 tracks at a time rather than the VS-2400CD 24 tracks and 384 V-tracks, and it can do so at no more than 1x speed, and it depends on having an R-BUS interface card in the computer. The Roland RPC-1 PCI card was discontinued a long time ago. I bought one used on ebay, and the driver was a disaster under Windows 7 64-bit - it killed all power management - I could no longer put the cmoputer to sleep. So I resold the card. Also, PCI slots are disappearing in newer computers, in favor of PCI-express. There is a V-Fire Firewire R-BUS interface. Unfortunately, it doesn't support Windows 64-bit, which I currently use. And the product has been "end of-lifed". My computer didn't come with a Firewire interface also. Many don't, though this can usually be remedied via an add-on card. I do have a PCI add-on card that provides Firewire, among other things. Unlike its big brother, the VS-2480, the VS-2400 does not have a SCSI interface, which rules out connecting SCSI hard disks - also rare beasts nowadays.

In fact, the only reliable way to export data to the computer until now has been to burn projects or tracks as WAV files to CD-R or CD-RW media. This is an excruciatingly slow process, as the VS-2400CD only burns at 4x speed, regardless of the media, and even if you install a faster CD burner in the machine, which I have previously tried.

I finally had enough with the VS-2400CD and started looking for a better solution to the PC data exchange problem. I'm happy to report that I was able to resolve the issue. The goal of this modification is to add a very fast eSATA port to the VS-2400CD so that modern external SATA hard drives can be connected, as well as potentially SATA card readers or SATA SSDs.

I bought many adapters, and spent much of the last month testing. There are the parts I recommend :

  1. A Kingwin SATA to IDE converter, model ADP-06, which costs about $10 online. I actually found this at Micro Center on closeout for $6.99 . This adapter comes with the Molex power adapter you need to power it directly from the VS-2400CD power supply. It also has a male 40-pin IDE connector, the same one found on the back of an IDE hard drive, so you can use the same IDE cable to connect it to the VS-2400CD motherboard. And finally, it supports UltraDMA speeds, which is required to work with the VS-2400CD.
  2. A BYTECC SATA male to SATA male adapter, model SATA-180MM, which costs about $4. This is a very rare adapter. Even in Silicon Valley, I couldn't find it locally anywhere. I had to order it from Newegg.
  3. A Kingwin eSATA PCI bracket , which costs $5 . I had one of these one lying around, it came with an eSATA enclosure. Mine was single port. This item is not common at retail stores. If you are in the SF Bay Area, Central Computers carries an eSATA bracket. It doesn't matter how many ports the bracket has, as only one will be used, and will be unscrewed from the bracket.
  4. A Thermalake BlacX ST0005U eSATA dock for 2.5/3.5 SATA drives, which costs $32. It comes with the eSATA cable you will need. It has no fan, which is very nice when recording. It has a cover door, so 2.5" drives aren't loose. The drive is still exposed, however, so this is not ideal for gigs. Finally, the dock supports both eSATA and USB 2.0. Most computers don't come with eSATA ports, but have USB 2.0 ports, which comes in handy for transferring the data to your computer. You could probably use any good eSATA+USB enclosure instead as long as it only supports one SATA drive, has only one eSATA port, and has no other gizmos like built-in card readers. I also looked for 2.5 eSATA enclosures, but couldn't find any that had a power supply for the drive. If you are really strapped for cash, it should be noted that there are less expensive eSATA/USB enclosures, in the $20 range, from Kingwin and Unitek, but they aren't as nice as the Thermalake.
  5. A SATA hard drive, either 2.5" or 3.5". The ideal capacity is 120GB, as that is the maximum the VS-2400CD will recognize. I tried a Western Digital Scorpio Blue 2.5" 120 GB SATA hard drive and it worked fine. I also verified that other hard drives are recognized. Seagate 3.5" 1.5 TB and 2 TB SATA drives also work, but only the first 120 GB of them can be used, so it is a waste. The actual hard drive I ended up using is a Western Digital WD1600 160GB SATA hard drive, which I got for $15 off Craigslist. Low capacity hard drives are hard to come by as new these days, so craigslist is probably your best bet. You can find some new laptop drives in the 100-200 GB range, but they don't come cheap due to their small size.
Thus, the total cost of the modification not including the SATA hard drive is $51.

You will need the following tools and other supplies :
  1. A Philips screwdriver.
  2. A smaller cross screwdriver.
  3. A drill.
  4. A metal drill bit.
  5. Superglue.
Here are the full steps for this modification :
  1. Open the VS-2400CD case and set it in the upright position
  2. Disconnect the IDE cable from the the built-in IDE hard drive
  3. Disconnect the Molex power cable from the built-in IDE hard drive
  4. Connect the available end of the IDE cable to the male IDE connector on the SATA bridge
  5. Connect the Molex power supply cable to the power connector SATA bridge
  6. Carefully "cicumsize" one end of the SATA male-male adapter. This means removing the plastic around the connector, so that you will be able to plug it into the SATA bridge. You can use small scissors such as nail scissors. The pieces of plastic will snap right off. You will also need to very slightly cut the plastic on the SATA female connector on the bridge. You will notice that this connection is loose. This is normal and we will resolve this later.
  7. Plug the SATA female cable from the eSATA bracket into the virgin end of the SATA male to male connector.
  8. Plug the eSATA dock into the eSATA bracket using the provided eSATA cable.
  9. Insert the SATA hard drive into the hard drive dock.
  10. Turn on the dock.
  11. Turn on the VS-2400CD.
  12. If you did everything correctly, it will complain about "Not any formatted drives". Use the function keys to let it format it.
  13. Restart the VS-2400CD after the format is complete.
  14. Verify that the VS-2400CD is working properly with the new hard drive. You are half-way done !
  15. Turn off both the VS-2400CD and the SATA dock.
  16. Disconnect the SATA male to male adapter from the bridge.
  17. Apply a very small amount of superglue to the side of the SATA female connector on the bridge. Make sure not to touch the contacts.
  18. Plug the SATA male to male adapter back into the bridge and wait a little bit. There should now be a tight fit.
  19. Disconnect the eSATA bracket from both the bridge and the dock.
  20. Using the small screwdriver, unscrew the eSATA connector from the bracket.
  21. Using a pencil, mark a hole the size of the eSATA connector in the front of the VS-2400CD case, next to the CD burner,
  22. Using a drill and a metal drill bit, carefully cut this hole.
  23. Using the small screwdriver, screw the eSATA connector to the hole in the VS-2400CD case.
  24. Plug the SATA cable back into the glued adapter on the bridge.
  25. Plug the SATA dock in the new eSATA connector in the VS-2400CD.
  26. Turn on both the dock and the VS-2400CD, in that order.
  27. Verify that everything still works and that the VS-2400CD boots up correctly, and sees the SATA drive.
  28. Unscrew and remove the drive tray that's holding the IDE hard drive.
  29. Close the VS-2400CD. You are now done !
You will notice that the VS-2400CD will no longer have a built-in hard drive. This means you will have to use an external drive through an eSATA dock or enclosure from now on. The VS-2400CD will no longer be fully self-contained. You will have to carry your eSATA dock and SATA drive with you. I think these should fit in the official Roland VS-2400CD case.

Here is a picture of what it looks like :

In a future blog post, I will explain how to take full advantage of this hardware modification, and transfer your VS-2400CD projects to your PC .

Windows 7 audio redux : Loudness equalization

I recently purchased a new laptop for my partner. He has been recording audio from tapes using Honestech's Audio Recorder Deluxe 2.0 . Everything was working fine on his old laptop running Vista.

But on the new laptop, something very strange happened : every time a song faded at the end, there was an ever-increasing amount of amplified hiss. This was extremely annoying. I verified by plugging headphones directly into the tape deck that the noise was not from the source.

I had to mess with the laptop for a while before I found the cause, buried in the Realtek audio settings :

Notice the checkmark for "Loudness equalization", and the explanation for it.
When I turned this effect off, and replayed the music files that were already recorded, everything was quiet between songs, as expected.

This setting really messes up with music playback in general. I think it is really better suited to voice. I'm not sure why Toshiba / Realtek / Microsoft decided to turn this on by default.

Note that the list of effects may vary by hardware device. The above list is from my desktop and is extensive. The laptop only offered a single effect option, which was Loudness Equalization

Windows 7 audio : Supported formats vs Default format

Windows 7 and/or some of the audio device drivers have a useful set of settings.
For example, the "Supported formats".
I have my device connected to an old Roland VM-3100Pro mixer which only supports 44.1kHz sampling rate PCM. So, I selected the following :

I thought this was sufficient to get sound working. I was wrong.
Despite my choices, Windows and Realtek had automatically selected the following "Default format" :

Notice that the 48 kHz rate. Never mind that I didn't select that in the "Supported formats". This should not happen. Windows should never pick a format that's been marked as unsupported.